Excel SVerweis – Einführung mit Beispiel

Mit der SVerweis Funktion können Sie Ihre Datenanalysen im Handumdrehen auf ein höheres Niveau bringen. Sobald Sie die grundlegende Vorgehensweise im Griff haben, werden Sie kaum mehr ohne SVerweis arbeiten wollen.

Von allen fortgeschrittenen Funktionen, ist der SVerweis eine der leistungsfähigsten und häufigst gebrauchten Funktionen. In diesem Artikel stellen wir Ihnen die Funktion im Detail vor, inclusive einer Übungsdatei zum runterladen und Video zum Wiederholen aller Schritte. Die Funktion sollte auf jeden Fall intensiv geübt werden, nur so werden Sie diese sicher beherrschen können.

Wozu verwendet man den Excel SVerweis?

Im folgenden Beispiel könnten Sie sich fragen „wieviel Umsatz hat Filiale 8 erzielt?“.

Die Antwort kann der SVerweis liefern. Dies kann enorm hilfreich sein, wenn Sie riesige Datenmengen analysieren.

Excel SVerweis

Der SVerweis durchsucht die erste Spalte einer Matrix und durchläuft die Zeile nach rechts, um den Wert einer Zelle zurückzugeben

Im obigen Beispiel wird in der ersten Spalte erst nach der Filialnummer gesucht und dann der Wert in der 4. Spalte zurückgeben.

SVerweis Syntax

Excel-SVerweis-Syntax

In unserem Beispiel wird dir Formel so ausgeschrieben: =SVERWEIS(8;B7:E16;4;FALSCH)

SVerweis-Beispiel

Suchkriterium:

Hier geben Sie den Wert ein nachdem Sie suchen (Wichtig: Dies kann auch eine andere Formel sein)

Datenbereich:

Legen Sie den Suchbereich (mindestens zwei Spalten weit) fest. Der Bereich muss mindestens die Spalte die den Zielwert enthält, enthalten. Er kann sich jedoch über mehrere Spalten nach rechts erstrecken.

Spaltenindex:

Die Spaltennummer, (in unserem Beispiel Spalte 4), in der sich der gewünschte Wert befindet.

(Tipp: Excel Lernen Artikel zur schnellen Ermittlung von Spaltennummern.)

Sortierkriterium:

Um eine genaue Übereinstimmung zu finden, verwenden Sie hier immer „FALSCH“ als Standardwert.

Platzhalter Suchkriterum

In vielen Situationen wissen Sie genau nach welchen Werten Sie suchen. Im Beispiel oben suchten wir nach Filiale 8. Aber stellen Sie sich vor Ihr Dokument hat hunderte oder tausende Zeilen. Wenn Sie zum Beispiel nur einen Teil des Namens einer Person wissen, können Sie durch Platzhalter (oder Wildcards) trotzdem den SVerweis anwenden.

Hier sind die gängigsten SVerweis Platzhalter:

SVerweis-Beispiel2

  • Die erste Funktion (Suchkriterium „Tom“) sucht nach dem kompletten Namen: Ergebnis 23
  • „Tob*“ sucht nach Zellen die mit „Tob“ beginnen, und gibt somit 20 als Ergebnis zurück
  • Ähnlich findet das Suchkriterium „*gang“ alle Zellen die mit „gang“ enden. Ergebnis 34
  • Sehr hilfreich ist der Platzhalter „????“. Jedes Fragezeichen stellt ein beliebiges Zeichen dar, in unserem Fall suchen wir nach Namen die 4 Buchstaben enthalten. Das Ergebnis hier is 24 (Susi)

Mehrfache Suchkriterien

Leider biete der SVerweis keine direkte Möglichkeit mehrere Kriterien zu verwenden. Stellen Sie sich vor, im obigen Beispiel haben Sie mehrere Verkäufer, die in allen Standorten arbeiten. Um den Umsatz eines bestimmten Verkäufers in einem bestimmten Standort zu ermitteln, benötigen Sie mehrere Suchkriterien (Standort und Name des Verkäufers).

Das löst man am besten über eine Hilfsspalte, die alle benötigten Kriterien enthält (hier unser Artikel zum Thema mehrfache Suchkriterien).

File:U+21FE.gif Hier geht’s zum Download der passenden Excel Übung

Video zur Wiederholung aller Schritte

Bei Problemen/Fragen zu dieser Funktion, einfach im Excel Forum vorbeischauen!

Neu: Eine leistungsstarke Alternative zum SVerweis stellt die Kombination aus den Index-Vergleich Funktionen dar.

14 Comments

  • Hallo,

    was genau bewirkt folgender Befehl für die gesamte Spalte B eingesetzt?

    =SVERWEIS(A3;Abfrage!A:B;2;FALSCH)

    Besonders der Teil mit „Abfrage!“ ist mir noch nicht ganz geläufig.

    Vielen Dank!

  • Hallo,
    bei der Vermietung unseres Ferienhauses gibt es verschiedene Saisonzeiten.Nun soll der zutreffende Übernachtungspreis je nach Datum in Spalte E ausgeworfen werden. Komme leider mit der Funktion WennUnd nicht klar.
    Die Saisonzeiten sind
    20.06. – 12.09. 93,00 €
    21.03. – 11.04. 67,00 €
    03.10. – 31.10. 67,00 €
    19.12. – 03.01. 67,00 €
    11.04. – 20.06. 59,00 €
    12.09. – 03.10. 59,00 €
    03.01. – 21.03. 45,00 €
    31.10. – 19.12. 45,00 € und so sieht meine Tabelle aus
    Beginntam Endetam Teilnehmer Tage Preis
    05.01.2015 08.01.2015 Lydia 3 45,00 €
    14.02.2015 21.02.2015 Erich 7 45,00 €
    14.03.2015 21.03.2015 Jacquelin 7 45,00 €
    Könnt Ihr mir eine Ratschlag geben?
    Vielen Dank.
    Burkhardt von Sicard

    • Andreas

      Hallo Burkhardt,

      bitte die Frage noch einmal ins Forum stellen. Ihr Problem ist, das Sie mit Datumsbereichen arbeiten (von bis) und anscheinend die Matrix nicht sortiert ist. Der SVerweis braucht eine Sortierung bei den Euro: Größe aufsteigend.
      Das ist im Forum leichter zu erklären.

      Gruß Andreas

      P.S. Sortierung bei Endet am nicht bei Euro

  • Hallo,
    könnten Sie mir helfen, mit sverweis oder sonst ein Excel-formeln

    wie ich das mache,

    Stundensatz nach Betriebszugehörigkeit erhöht sich, von 8.50 Euro Ausgehend nach 1 Jahr auf 8,70 Euro nach 2 Jahren auf 9,00 Euro etc. ?

    Hoffe auf Lösung
    Herzlichen Dank im Voraus,
    Yan Wu

    • Andreas

      Hallo Yan Wu,
      nimm den SVerweis. Erstelle eine Hilfstabelle, die die Daten der Jahre und des Stundensatzes enthält. Die Jahre und den Stundensatz untereinander aufschreiben: 0; 8,50€, 1; 8,70€, 2; 9,00€
      Jetzt kommt es darauf an, wie die Tabelle aufgebaut ist. Entweder nur der SVerweis oder zusammen mit der Wenn-Funktion. Aber auf jeden Fall der Bereich_Verweis beim SVerweis auf wahr setzen.

      beste Grüße Andreas

  • Hallo zusammen,

    ich suche eine Möglichkeit einen kleinen Bereich von etwa 5×6 Zellen zu vervielfältigen. Ich habe vor damit so eine Art Karte zu erstellen mit den nötigen Infos über die Teilnehmer. Ehepaare bekommen jeweils nur eine Karte. Dazu soll zusätzlich ein Abgleich mit der vorherigen Zeile stattfinden, ob die Nachnamen identisch sind.

    Dabei hat jede Zelle seine eigene Funktion und entsprechende Formel. Den Inhalt beziehe aus einer anderen Tabelle. Den Bereich markieren und dann an der gewünschten Stelle zu platzieren klappt nur bedingt. Die Formel wird dann nicht richtig angepasst. Ich brauche diese Bereiche etwa 100 Mal. Ich müsste also jede Zelle anpassen. Da gibt es doch bestimmt eine bequemere Lösung?

    Also nochmal zum Vorhaben ich möchte einen bereits formatierten Bereich mit all seinen Formeln kopieren und vervielfältigen, sodass die Formeln im X-ten Bereich sich automatisch die Infos aus der X-ten Zeile der Hilfstabelle beziehen.

  • Guten Tag,
    leider scheitere ich schon an der Hürde der Platzhalter.
    Selbst mit der deckungsgleichen Formel wie im Beispiel bekomme ich nv oder ein falsches Ergebnis???Was ist passiert?

    Name Alter
    Tom 23 =SVERWEIS(„Tom“;B2:D6;2;FALSCH) #NV
    Tobias 20 =SVERWEIS(„Tob*“;B3:D7;2;FALSCH) 20
    Wolfgang 34 =SVERWEIS(„*gang“;B2:D6;2;FALSCH) 34
    Susi 24 =SVERWEIS(„????“;B2:D6;2;FALSCH) Alter
    Maximilian45 =SVERWEIS(„*mili“;B2:D6;2;FALSCH) #NV

    • Andreas

      Hallo Sarah,

      im Artikel hat sich leider ein kleiner Fehler eingeschlichen. Die Matrix ist nicht B2:D6 sondern B3:D7; Überschriften müssen nicht in der Matrix enthalten sein, dafür aber die gesamte Tabelle.
      Du hast bei Tobias die richtige Matrix, deshalb ist dein Ergebnis richtig. Wolfgang hat zwar die falsche Matrix, doch die Werte liegen am richtigen Platz innerhalb der falschen Matrix, deshalb richtiges Ergebnis. Susi bekommt als Ergebnis Alter, weil in der Matrix in B2 Name steht. Name hat 4 Buchstaben genauso wie Susi. Der SVerweis hört beim ersten gefundenen Ergebnis auf zu suchen, deshalb bekommst du Alter und nicht 24. #NV bei Maximilian, weil diese Werte außerhalb der Matrix liegen.
      #NV bei Tom, da bin ich mir nicht ganz sicher, doch gehe ich zu 99% davon aus, dass du die 23 als Text und nicht als Zahl formatiert hast.

      Schreibe die Matrix in den Formeln neu und ändere die Formatierung das Alters bei Tom, dann wird es richtig werden.

      beste Grüße Andreas

  • Ich bin noch nicht so excel erprobt, möchte aber für folgendes eine Tabelle erstellen:

    Ich habe z.B. in den Spalten A1 bis A10 jeweils eine Dropdownlistenauswahl mit Namen.
    In der Spalte daneben, also B1 bis B10 soll dann je nach Namensauswahl der Stundensatz eingeblendet werden.

    Die Namen sind z.B. in den Spalten K1 bis K10 und die Stundensätze in L1 bis L10 eingetragen.
    Wie müssen die Formeln in B1 bis B10 aussehen?

    Vielen Dank im Voraus!

  • Hallo zusammen,
    Anfänger durch und durch.
    ich bin am Verzweifeln. Ihr spezis bekommt das aber bestimmt hin.
    Bei „ =SVERWEIS(B14;B5:E14;4;FALSCH“ möchte ich das Suchriterium nicht in einer Zahl eingeben, sondern über ein Text. In dem oben gezeigten Beispiel über eine, von einer Combibox vorgegebenen Stadt. Danke im Vorfeld an die/den Profi.
    Mit besten Gruß
    michael

  • Hallo Liebes Forenteam,

    ich bin in der Ausbildung zum Büromenschen, oder, wie es neuerdings heißt, zum Kaufmann im Büromanagement, da mein Ausbilder mit anderen Dingen beschäftigt ist, gab er mir die Aufgabe, mittels Sverweis nach einer Bestimmten Zahl in einer Tabelle zu suchen.
    Ich stehe seit dem mit Excel auf Kriegsfuß, weil ich es nicht verstehe.
    Mir wäre geholfen, wenn mir jemand erklären würde, was Excel genau macht, wenn ich mich mit dem Sverweis auf die Suche mache. Die Tabelle stell ich hier besser nicht ein, Datenschutzrechtliche Gründe und so.
    Danke schon mal im vor raus

    Mfg. Flames 96

  • Guten Tag,
    ich möchte in meiner Excel mehrere wenn dann Funktionen verknüpfen…
    Beispiel:
    Erntemengen: Feuchtigkeit: Erntemenge trocken:
    10.550 kg 14,5% 10.550 kg
    8.690 kg 16,5% ?
    8.590 kg 18,5% ?
    12.980 kg 17,6 % ?

    Wenn Feuchtigkeit 14,5 %, = 15,6%, < 16,6% dann Erntemenge trocken = Erntemenge * 0,988
    …. weitere 5 funktionen

    Wie stelle ich das an?
    Mit freundlichen Grüßen

  • Hallo zusammen!

    Ich habe eine Liste mit 25.000 Artikeln und einem Satzaufbau

    Artikelnummer / Land / Größe / Preis / Rabatt

    es gibt unterschiedliche Rabatte in den Ländern.

    Beispiel:

    1234 / DE / 001 / 100,00 / 30%
    1234 / AT / 001 / 100,00 / 40%
    1234 / CH / 001 / 120,00 / 50%
    1234 / DE / 002 / 120,00 / 30%
    1234 / CH / 002 / 150,00 / 50%
    4567 / DE / 001 / 50,00 / 40%
    4567 / CH / 001 / 70,00 / 20%

    Nun sollen alle Rabatte je Artikel dem deutschen Rabatt gleichgesetzt werden.

    Ergebnis im Beispiel:

    1234 / DE / 001 / 100,00 / 30%
    1234 / AT / 001 / 100,00 / 30%
    1234 / CH / 001 / 120,00 / 30%
    1234 / DE / 002 / 120,00 / 30%
    1234 / CH / 002 / 150,00 / 30%
    4567 / DE / 001 / 50,00 / 40%
    4567 / CH / 001 / 70,00 / 40%

    Wie kriege ich das hin?

    Vielen Dank im Voraus für Eure Unterstützung!

    Schöne Grüße
    Andi

  • Hallo ich habe ein Excel Problem, sollte eigentlich ein SVerweis sein, ich komme nicht darauf was ich Falsch mache.
    Also konkret ich muss aus 2 verschiedenen Exceltabellen die Leistungsmenge vergleichen, wobei manche Produkte auf verschiedenen Kostenstellen laufen; z.B.

    Produkt A Kostenstelle 1234 Leistungsmenge 5000
    Produkt A Kostenstelle 4567 Leistungsmenge 500
    Produkt B Kostenstelle 1234 Leistungsmenge 1000

    Konkret gesagt als Suchkriterium habe ich 2 (nebeneinanderliegene) Zellen (bisher hatte ich immer nur eine Zelle das hat prima Funktioniert), als Fehler Kommt immer „‚WERT! wer kann mir helfen?

Frage oder Kommentar zu diesem Artikel?



Tipps & Artikel auf Facebook