Excel Zählenwenn Einführung mit Beispiel

Die ZÄHLENWENN Funktion ist im Prinzip  eine Kombination aus der WENN und ZÄHLEN Funktion in Excel. Diese Kombination ermöglicht es Ihnen, die Anzahl der Daten in einer ausgewählten Gruppe von Zellen zu zählen. Der WENN-Teil der Funktion bestimmt, welche Zellen die vorgegebenen Kriterien erfüllen und der ZÄHLEN-Teil gibt die Anzahl der Zellen an.

Wenn Sie die SUMMEWENN Funktion bereits kennen, wird Ihnen ZÄHLENWENN sicher keine Probleme zubereiten. Die beiden Funktionen sind sich sehr ähnlich und der Aufbau identisch.

Excel Zählenwenn Funktion

Hier im Beispiel (Datei runterladen) wollen wir die Anzahl der Verkäufer ermitteln, die einen Umsatz von über 200.000 Euro erzielt haben. Weiter unten erklären wir Schritt für Schritt wie die Funktion funktioniert.

excel-zaehlenwenn-funktion

Zählenwenn Syntax

excel-zaehlenwenn-1

Schritt für Schritt Beispiel (Datei runterladen)

Wir wollen im Beispiel oben die Anzahl der Verkäufer mit dem höchsten Umsatz ermitteln. Wie Sie im Syntax sehen, besteht die Zählenwenn Funktion aus zwei Teilen:

  1. Suchbereich – in dem sich die Werte, die Sie zählen wollen befinden.
    Als erstes bestimmen wir den Bereich, der die gewünschten Suchkriterien enthält. Wir wollen Umsatz >200.000 finden, also wählen Sie hier den Bereich C3:C13 aus.
  2. Suchkriterien – Kriterien können aus Zahlen, Namen, > < = Zeichen bestehen.
    In unserem Beispiel können wir entweder mit Zellreferenz arbeiten, d.h. wir geben einfach C16 ein. Die Zelle C16 muss dann in diesem Fall das Kriterium >200.000 enthalten. So ist es einfach später Kriterien zu ändern. Alternativ können Sie auch das Kriterium direkt in die Funktion so eingeben: „>200.000“.

Wichtig: Wenn > < = Zeichen direkt in der Funktion angewendet werden,  müssen diese immer in Anführungszeichen gesetzt werden (z.B „>200.000“).

Übersicht der Kriterienarten

  • Zahlen: z.B. 32 (Anzahl der Zellen mit dem Wert 32), „32“ (gleiches Ergebnis wie 32), „>=30“ (mindestens 30), „<>32“ (Zellen die nicht den Wert 32 haben)
  • Text: z.B. „Thomas“ (Zellen mit dem Wert „Thomas“), „<>Thomas“ (Zellen die nicht Thomas enthalten)
  • Text Platzhalter: z.B. „T*“ (Zellen die mit T beginnen)
  • Zellbezug: Wenn Sie in Zelle C16 ein Kriterium als Zahl angeben wollen (z.B. 200.000 wie im Beispiel oben) und dann Werte grösser als 200.000 finden wollen braucht man das &-Zeichen: „>“&C16

Ab Excel 2007: Mehrere Kriterien in einer Funktion verwenden

Seit Excel 2007 gibt es die ZÄHLENWENNS Funktion. Diese Funktion ermöglicht es mehr als ein Kriterium zu verwenden. Zum Beispiel können Sie so die Anzahl der Verkäufer mit mindestens 200.000 Umsatz UND mindestens 150.000 Profit ermitteln.

In unserem Beispiele würde das dann so aussehen (Ergebnis:2):
=ZÄHLENWENNS(C3:C13;“>200000″;D3:D13;“>150000″) 

File:U+21FE.gif Bei Fragen einfach im neuen Excel Forum vorbeischauen. Wir helfen gerne!

9 Comments

  • Datei Excel Zählen Wenn wird als Datei .xls heruntergeladen.
    Lässt sich mit Excel 2003 nicht öffnen bzw. die Anzeige erfolgt mit Steuerzeichen.
    Meldung: Inkompatible Formel, Berechnung nicht möglich.

  • Max

    Die Datei war als xlsx (Excel 2007) gespeichert. Habe gerade eine 2003 kompatible Version hochgeladen. Jetzt müsste es funktionieren.

  • Wie erkennt excel denn, dass in Zelle C16 ein Kriterium ist?
    Gibt man dann in C16 folgendes ein: ‚>200000? Also mit Strich?

    Mein Ziel ist dies: Zählen, wenn der Wert in der Zelle größer als 20% des Mittelwerts sind. Der Mittelwert wird gebildet aus den Werten der entsprechenden Zeile.
    Ist es richtig so? ZÄHLENWENN(C3:C83);“>“MITTELWERT(A3:F3) ?

    • Andreas

      Hallo Lisa,

      die Formel für Zählenwenn muss anders aufgebaut sein, ungefähr so:
      =ZÄHLENWENN(C3:C83;MITTELWERT(A3:F3)>5)
      Doch um Genaueres sagen zu können, muss ich deine Tabelle kennen. Zählenwenn bezieht sich nur auf Zellen, in denen ein Eintrag vorhanden ist.
      Wie erkennt Excel ein Kriterium? Das ist der Eintrag einer Zelle als Zahl, Text oder Mix aus Beidem. Ein Kriterium wird immer erst in der Formel gebildet. Um in deinem Beispiel zu bleiben: in C16 steht 20000, dann kann in der Formel stehen: C16>20000
      Das bedeutet, C16 ist größer als 20000 Oder C16 >0, bedeutet in C16 steht eine Zahl größer als Null oder Text usw.
      Du hast deine Formel so aufgebaut, das nur in der ersten Zeile gesucht wird. Ist das richtig so, oder soll Zeile für Zeile durchsucht und danach gezählt werden, welche Zeilen größer als der Mittelwert +20% sind?

      Am Besten ist es, wenn du dich im Forum anmeldest und dort dein Problem noch einmal schilderst, am besten mit einer kleinen Beispieltabelle im Anhang. Dort kann dir viel besser geholfen werden.

      Gruß Andreas

  • A1=1
    A2=2
    A3= =WENN(A1=1;““;“ABC“)
    A4=““
    A5 = =ANZAHL2(A1:A4)
    Ergebnis = 3. Ich möchte aber 2 sichtbare sehen.

    • Andreas

      Hallo,

      Anzahl2 bedeutet nicht leere Zellen, in deinem Beispiel von A1 bis A4. A1 und A2 beinhalten jeweils eine Zahl, sind demzufolge nicht leer. A3 beinhaltet eine Formel, demzufolge auch nicht leer. Deshalb wird durch deine Formel in A5 eine 3 wieder gegeben.
      „“ bedeutet für Excel imaginären Text (keine Zahl), der nicht angezeigt werden soll. Deshalb müsste bei dir in A5 als Ergebnis normaler Weise eine 4 stehen.
      Für Excel sehen deine Zellen A1 bis A4 folgender maßen aus:
      A1 = Zahl (nicht leer)
      A2 = Zahl (nicht leer)
      A3 = Text, aber nicht sichtbar (nicht leer)
      A4 = Text, aber nicht sichtbar (nicht leer)

      Das, was du oben beschrieben hast, vor allem A4=““ und dann als Ergebnis von A1 bis A4 nur eine 3, ist überhaupt nicht möglich.

      Gruß Andreas

  • Hallo, bekomme bei folgender Formel einen Fehler, warum?

    =WENN(E11:E47=““;“X“;ZÄHLENWENN(E11:E47;„F*“))

    Zuerst soll in der Spalte Ex geprüft werden, ob ein Eintrag vorhanden ist, wenn nein – dann ein X , wenn ja sollen alle Einträge gezählt werden, die mit einem „F“ beginnen.

    Hat jemand eine Idee?
    Danke

  • Ich habe eine Frage, drei Antwortmöglichkeiten – jede Antwortmöglichkeit hat eine eigene Spalte, wenn die Antwort JA ist habe ich ein X reingeschrieben, sonst ist das Feld leer.
    Wie werte ich die Antwortmöglichkeiten einzeln aus?
    Danke im Voraus!

    • Andreas

      Hallo Kathi,

      wenn du spaltenweise auszählen möchtest, dann bitte folgendermaßen:
      =ZÄHLENWENN(C2:C15;“x“)

      Ich habe in der Spalte C von C2 bis C5 beliebige x gesetzt (insgesamt 5). In C17 habe ich obige Formel geschrieben, Ergebnis: 5

      Mit ZählenWenn wird immer eine Spalte oder eine Zeile ausgelesen.

      beste Grüße Andreas

Frage oder Kommentar zu diesem Artikel?



Tipps & Artikel auf Facebook